Uploaded image for project: 'StreamSets Data Collector'
  1. StreamSets Data Collector
  2. SDC-13331

Upgrade Kinesis producer library to 0.12.11

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Resolved
    • Priority: P3 (Limited Impact)
    • Resolution: Fixed
    • Affects Version/s: 3.13.0
    • Fix Version/s: 3.14.0
    • Component/s: None
    • Labels:
    • Target Version/s:
    • Sprint:
      Platform Sprint 10
    • Story Points:
      1
    • Testing Status:
      Manual Testing
    • Testing Description:
      Hide
      - Create VM using a CentOS 7 guest Operative System. You can use Virtual Box for instance.
      - Upload all the SDC dist directory on the new VM. The SDC must be compiled in a version prior to this change.
      - Run the SDC on the VM
      - Create a pipeline that writes on a Kinesis Stream. You can use the pipeline example attached on ESC-638
      - You will see the exception described on ESC-638
      - Now you compile the new version of the SDC that contains this change.
      - Update the dist directory on the VM.
      - Run SDC
      - Run the same pipeline and you will see the records are written on the Kinesis Stream correctly.

      Show
      - Create VM using a CentOS 7 guest Operative System. You can use Virtual Box for instance. - Upload all the SDC dist directory on the new VM. The SDC must be compiled in a version prior to this change. - Run the SDC on the VM - Create a pipeline that writes on a Kinesis Stream. You can use the pipeline example attached on ESC-638 - You will see the exception described on ESC-638 - Now you compile the new version of the SDC that contains this change. - Update the dist directory on the VM. - Run SDC - Run the same pipeline and you will see the records are written on the Kinesis Stream correctly.
    • Team:
      Platform

      Description

      KPL (0.12.10) has wrong readme information about the Glibc version which is causing an error on Linux versions based on Debian ( e.g. Ubuntu 16.04).

      The Readme.md requires Linux distributions with Glibc 2.9 or later, but in fact, it runs against Glibc 2.25 symbols. 

      KPL(0.12.11) should solve this issue.

       

       

        Attachments

          Activity

            People

            Assignee:
            toni Toni Martinez
            Reporter:
            danilo Danilo Viana
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: